Truecrypt, wxGTK update and lots of changes

Submitted by dag on Thu, 2008/09/18 - 23:48

As we speak I am pushing the new wxGTK updates to the repository. It was needed in order to have a truecrypt package, but also required a lot of rebuilds and updates of packages that depended on wxGTK.

The good news is that this may bring us a bit closer to compatibility with EPEL, the bad thing is that the audacity builds fail (old and new versions) so for the time being no audacity, or no wxGTK update...

I also tried building the new VLC media player (0.9.2) but it had issues of its own so I did a rebuild of VLC 0.8.6i until I can fix it.

Let me know if you have any issues other than the audacity one.

Unable to update VLC

Even with VLC 8.6i, I still get missing dependencies on libwx..., such as libwx_gtk2... and libwx-base... when I try to update VLC on CentOS 5.2. I have both wxGTK and wxGTK-devel installed (2.6.3-1). I don't know what packages contain the missing libraries, but the installation package for VLC either doesn't know what they are, or they aren't available for CentOS 5.2.

Works fine here

[dag@rhun ~]$ rpm -q wxGTK vlc
wxGTK-2.8.8-1.el5.rf
vlc-0.8.6i-1.el5.rf

Missing libwx... dependencies for VLC

I tried to update VLC on CentOS 5.2 today, but have consistently failed to do so because of missing dependencies - see list below. I have wxGTK and wxGTK-devel installed (version 2.5.3-1) and all installed components are up-to-date.

Missing Dependencies:

Error: Missing Dependency: libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by package vlc
Error: Missing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_baseu-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_richtext-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_qa-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_html-2.8.so.0()(64bit) is needed by package vlc
Error: Missing Dependency: libwx_baseu_net-2.8.so.0()(64bit) is needed by package vlc

A resolution for this problem would be appreciated, as well as a buildable/installable 9.2 version of VLC. Thanks.

What's wrong with

What's wrong with wxGTK-2.8.8-1.el5.rf.x86_64.rpm ?

Feel free to try and build VLC 9.2 on CentOS 5.2 and send me the buildlog. I spend more than 6 hours to work around several compile problems and simply gave up. ffmpeg is the hardest part.

Maybe you can do it, it would save me a lot of time.

seems like a dependency loop

Seems like there is a dependency loop...

If I try a "yum update" yum finds vlc 8.6i to update but fails on the wxGTK stuff....

when dooing a "yum update wxGTK" it finds a new wxGTK, but also a dependency for vlc 8.6i and updates/installs the lot just fine....
###
Dependency Installed: directfb.x86_64 0:1.0.1-1.el5.rf libshout.x86_64 0:2.2.2-1.el5.rf libsndfile.x86_64 0:1.0.17-1.el5.rf svgalib.x86_64 0:1.9.25-1.el5.rf twolame.x86_64 0:0.3.12-1.el5.rf
Updated: wxGTK.x86_64 0:2.8.8-1.el5.rf
Dependency Updated: vlc.x86_64 0:0.8.6i-1.el5.rf
Complete!
###

After the update vlc is indeed 8.6i now and working and "yum update" finds no packages to update anymore....

Update woes

Hi,

I'm using CentOS 5.2 with RPMForge repos enabled on all our desktops, at work and at home. This morning I launched an update and saw that the wxGTK update created a mess: VLC and AMule depend on wxGTK 2.8, Audacity depends on wxGTK 2.6.

[rant]

Why can't things like these rather be put in some testing repository until they work ok? I'd rather go with some slightly outdated but available software than have some mutually excluding updates. This sort of thing usually only happens with distros like Arch or Gentoo, but that's exactly the reason why I use CentOS.

[/rant]

Apart from that, keep up the good work :o)

Missing Dependency because of perl-Wx on CentOS-5.2

Except for audacity there also seem to be problems when having perl-Wx installed. perl-Wx is a dependency for inkscape. After uninstalling perl-Wx and it dependencies (yum remove perl-Wx), updating vlc works.

Reinstalling inkscape (yum install inkscape) doesn't work and errors-out with:

Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu_xml-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6.2)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_media-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu_xml-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_adv-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_stc-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu_net-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.3)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_media-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_baseu-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0()(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_stc-2.6.so.0(WXU_2.6)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_media-2.6.so.0(WXU_2.6.2)(64bit) is needed by package perl-Wx
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2)(64bit) is needed by package perl-Wx

My guess is that rebuild of perl-Wx would make it possible to install inkscape again.

Cheers,
Niels

Get your facts straight.

RPMforge has no inkscape that was build against Wx (t be honest, I didn't know that was even possible). So you either do not have inkscape installed from RPMforge, or you need to get your facts straight before posting here.

I have the same problem

I have the same problem (missing dependecies of perl-Wx) when trying to install Inkscape 0.46 on CentOS 5. Looks like a dependency glitch a bit down the chain: "repoquery --repoid=rpmforge --alldeps --requires inkscape" includes "perl(XML::XQL)", and then "repoquery --repoid=rpmforge --alldeps --whatrequires perl-Wx" includes "perl-XML-XQL-0:0.68-2.el5.rf.noarch".

[dag@rhun ~]$ rpm -q inkscape

[dag@rhun ~]$ rpm -q inkscape perl-Wx perl-XML-XQL wxGTK
inkscape-0.46-1.el5.rf
package perl-Wx is not installed
perl-XML-XQL-0.68-2.el5.rf
wxGTK-2.8.8-1.el5.rf

[dag@rhun ~]$ rpm -qR perl-XML-XQL
/usr/bin/perl
perl(Carp)
perl(Date::Manip)
perl(Getopt::Std)
perl(Parse::Yapp::Driver)
perl(XML::RegExp)
perl(XML::XQL)
perl(XML::XQL::DOM)
perl(XML::XQL::Date)
perl(XML::XQL::DirXQL)
perl(XML::XQL::Parser)
perl(base)
perl(fields)
perl(overload)
perl(strict)
perl(vars)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

The problem seems to be that Yum wants to satisfy the perl(Parse::Yapp::Driver) dependency that perl-Wx is providing as well.

Sadly, no version of perl-Wx is buildable on my system against wxGTK 2.8.8. So the easiest way to undo this is to install perl-Parse-Yapp and uninstall perl-Wx.

Or drop Yum and use Apt :-)